Q47Network AssuranceMultiple answers
Which two protocols work with YANG data models? (Choose two.)
Select 2 answers.
← → navigate · a answer
Discussion · 3
9
The answers are "B" and "D".
https://ftp.ripe.net/rfc/v3test/test8345.v2v3.html
"8. Security Considerations
The YANG modules specified in this document define a schema for data that is intended to be accessed via network management protocols such as NETCONF [RFC6241] or RESTCONF [RFC8040]. The lowest NETCONF layer is the secure transport layer, and the mandatory-to-implement secure transport is Secure Shell (SSH) [RFC6242]. The lowest RESTCONF layer is HTTPS, and the mandatory-to-implement secure transport is TLS [RFC5246]."
3
B & D
Study Guide
Data Models and Supporting Protocols
This section gives a high-level overview of some of the most common
data models and tools and how they are used in a programmatic
approach:
Yet Another Next Generation (YANG) modeling language
Network Configuration Protocol (NETCONF) , defined in RFC 4741 and RFC 6241, is an IETF standard protocol that uses the YANG data models to communicate with the various
devices on the network.
RESTCONF , defined in RFC 8040, is used to programmatically interface
with data defined in YANG models while also using the datastore concepts
defined in NETCONF.
1
restconf along with netconf